WP all import and WPML, stock sync issue during cron job


I’m using WP all import to update WooCommerce products stock. WPML is installed, 2 languages, only variable products, all duplicated. When I manually run the import from the “run import” button of the import manager, everything works great. The variations products stock are well updated, for main product language and duplicate one. BUT, when I activate the same import from a CRON job, only the main language products variation stock are updated. The duplicate product stock stay unchanged. Short video of the process here :


It looks like if the option “Increase speed by disabling do_action calls in wp_insert_post during import.” were automatically enable for CRON jobs.

Any idea to force this action, or to force saving/updating/duplicate products and variations after/during import to affect duplicated products would be appreciate.

, , eds 3 years 2020-06-06T06:10:23-05:00 0 Answers 115 views 0

Leave an answer