WordPress REST API in Integromat: How to overcome “Sorry, you are not allowed to list users / edit this…”

Question

I am attempting to connect Integromat to my WordPress install.

I have successfully enabled visibility of custom post types in Integromat by registering my custom post types with show_in_rest. (And, though I have also used show_in_rest for my custom taxonomies, there seems no way to surface these in Integromat, but that’s not the question).

However, in the Integromat dropdowns for the following, I see these REST API permissions errors:

  • Categories: Sorry, you are not allowed to edit terms in this taxonomy
  • Tags: Sorry, you are not allowed to edit terms in this taxonomy
  • Author Sorry, you are not allowed to list users

This is strange to me. I have provably forced custom post types and taxonomies to be seen by Integromat by using show_in_rest (and I had to deactive my Disable REST API plugin – what is preventing Integromat from getting a list of out-of-the-box Categories/Tags and Users?

Is there some equivalent show_in_rest setting that applies to these, too?

Any solution that requires things like passing different authentication headers may be irrelevant for me, as Integromat wouldn’t support that, it’s supposed to hide that from me. Doesn’t mean Integromat may not have a fix to make. But, ideally, any solution is on my own WordPress install.

0
Robert Andrews 2 months 0 Answers 8 views 0

Leave an answer