WordPress custom post type as homepage with homepage url

Question

I was able to set a custom post type as the homepage for a woocommerce site I am building.

The problem is that when I do this, the homepage url does not display. (i.e. https://mywebsite.com).

Instead it displays as (https://mywebsite.com/post-type/post-name).

Using filters I was able to get rid of the post slug, but the name is still now present when set to the homepage. If I go to (https://mywebsite.com) the url bar displays (https://mywebsite.com/post-name).

Does anyone know how I can get rid of post-name in the URL when setting this as the homepage?

0
, Nicholas Finch 2 months 0 Answers 34 views 0

Leave an answer