Why does WordPress automatically redirect URLs with the parameter “name=” to a different page?

Question

How do I disable this automatic redirect of the name variable so that I can use it on my call booking landing page?

I’m setting up a call booking page here: https://www.themcmethod.com/talk/

I want to add the URL parameters “name” and “email” so I can automatically populate the form.

Problem is, when I add the “name” parameter, WordPress assumes I want to redirect to a page with the name in it.

For example…

https://www.themcmethod.com/talk/?email=john@google.com redirects to the call booking page fine, but if I add a name field, it redirects to the most likely page on the website.

Therefore, https://www.themcmethod.com/talk/?name=John&email=john@google.com redirects to my podcast with John Carlton https://www.themcmethod.com/john-carlton-on-6-key-elements-of-powerful-profitable-email-marketing/

And https://www.themcmethod.com/talk/?name=Mary&email=mary@google.com redirects to a lightbox popup with “Mary” in the title.

How do I disable this automatic redirect of the name variable?

I’ve tried disabling all plugins, but it doesn’t work.

I’ve tried disabling that wordpress automatic guessing function, but it didn’t work either.

It seems like there’s two steps.

WordPress takes name= and redirects it to the most likely URL, so name=John redirects to themcmethod.com/john.

Then the other step kicks in, whereby if themcmethod.com/john is a 404, wordpress automatically redirects to the most likely page with “John” in the title.

Apparently the guessing function is good for SEO, so I don’t want (or need, for that matter) to disable it. I just want to stop the name=John redirect.

Any ideas? Thx!

0
, , John McIntyre 2 years 2019-11-24T21:16:43-05:00 0 Answers 90 views 0

Leave an answer

Browse
Browse