Warning: include(): https:// wrapper is disabled in the server configuration by allow_url_include=0

Question

I am trying to make a email template for my wordpress site. So I tried to include the HTML mockup that was given to me, but instead of putting it directly on the same file, I would like to include() instead. Here is what my code looks like that’s returning the error.

    include(get_template_directory_uri() . '/inc/email_templates/quote.php');
    $message = $top_of_body;
    $message .= "<h1><strong>Name</strong></h1>: " .  $name . "rn";
    $message .= "<h1><strong>E-mail</strong></h1>: " . $fromEmail . "rn";
    $message .= "<p>" . $comments . "</p>";
    $message .= $bottom_of_body;
    $headers = "MIME-Version: 1.0" . "rn";
    $headers .= "Content-Type: text/html; charset=ISO-8859-1" . "rn";
    $headers .= "From: " . $fromEmail . "rn";
    $headers .= "Reply-To: " . $fromEmail . "rn";

I tested doing the HTML for email in the same file and it works, so the problem only occurs on the include. How do I “enable” this feature?

This is my error Warning: include(): https:// wrapper is disabled in the server configuration by allow_url_include=0

0
davidb3rn 4 months 0 Answers 26 views 0

Leave an answer