Want to change the "project" name in the url

Question

I created a specific page named "projets" (in French) and put all the projects inside (I’m using Divi). Now I have two pages :

  • one is the right one using the right url "projets"
  • another one is not visible at all in my pages list but is available on the browser when you enter the url using "project".

I tried to check the categories and the permalinks but everything seems to work fine for all of my blogs posts for example.

I also have Yoast installed and there is a possibility to remove the category suffix, but I’m a little bit afraid as it can break my entire links inside my website and make redirections Google dos not really like.

I think WP created the default "project" page from the default "project" category and I don’t know how to fix it.

My projects are listed on my "projets" page I created but when I edit each project, there is "project" just before the slug and not "projet" in French.

When I make a quick edition, the slug is the correct one on each projects.

When I open a project from my "projets" page (in French), there is a redirection to the "project" url page (in English).

Thank you in advance for your feedback.

in progress 0
Linode 2 months 2021-09-20T09:50:13-05:00 0 Answer 0 views 0

Answer ( 1 )

    0
    2021-09-22T13:53:12-05:00

    Is Projects a custom post type, or a category/tag/taxonomy under Posts? If it’s a custom post type, most likely what you’ll need to do is change the settings that allow/define an archive page for the post type, and change the rewrite settings on the post type to have it set “projets” instead of “projects”.

Leave an answer

Browse
Browse