Transfer to HTTPS – mixed content on main page only


I am having problem with mixed content on the website after enabling SSL.
The strage thing about it is, only main page is affected (though the same assets are used through the whole website). The main page is made with elementor.

What I did:

  1. Changed all to HTTPS in WP settings
  2. Changed all necesarry things in wp_config.php to HTTPS
  3. Replaced all occurences of http://domain with https://domain in database
  4. Checked no http in css files in wp-content/uploads/elementor/css
  5. Added to .htaccess rule to overwrite all non-HTTPS requests to HTTPS (this alone should be enough?)
  6. Disabled all plugins that does not affect the web functionality.
  7. Replaced the main page with another copy, now the previous main page works well and the problem is on the copy (that is set as default main page).

At first I though after doing all this stuff, it has to be the browser-related problem (thin VS thick client). But then I checked more browsers (all latest versions to the date except IE):

Chrome: no problems. Except my friend’s chrome was the same, today it showed the mixed content messages too.

Firefox: insecure content main page only

Opera: insecure content main page only

Internet Explorer: no problems.

Obviously, I did reload the webpages and cleared the cache.

Any idea would be much appreciated. Th website can be accessed at

, , , Jiri 3 years 2019-11-30T08:14:55-05:00 0 Answers 81 views 0

Leave an answer