redirect – Every newly created page links to the same deleted page


I came across a weird issue in WordPress that I have no idea how to solve. It actually happened when my wife was adding pages to the website, so I don’t know exactly what she clicked, but she’s claiming she just simply added the page and it started behaving weird.

So the issue: She added as new page, let’s call it A. It worked fine. According to her, immediately after that she added another page. When she previewed this new page, the content on the page was actually the content of A for whatever reason. She created a few more pages, published them, and all of them show as A, even though they have unique URLs. I deleted A and emptied the bin and it still shows A for every new page created. I checked the database and A is NOT in it, but is still being shown for whatever reason, which got me thinking it must be some kind of a caching issue. I cleared the browser cache, still shows A. Cleared the caches of all plugins, still shows A. Disabled all the plugins, still shows A. There is a plugin called LiteSpeed Cache which I suspected might be the issue, so I deleted the plugin, and it still shows A for every new page created. I tried different browsers, different devices, always the same. The page that doesn’t exist in the database is being loaded and redirected to every time I publish a new page. Also, if I type in a non-existent address on my domain, it redirects to A, so 404 error redirects to A.

If I then change the permalink option to “plain”, somehow previewing every new page links to the homepage. However, when then clicking the link to the new page in the menu, it leads again to A. But with the “plain” permalinks, the 404 error now correctly redirects to whatever it is supposed to be, not A.

Don’t know if it matters, but we’re using Divi theme and page builder.

I would appreciate any help or suggestion since we’re completely stuck and can’t publish any new pages whatsoever.

user2923638 1 year 2022-11-22T14:47:03-05:00 0 Answers 0 views 0

Leave an answer