plugins – Prevent WordPress from sending set-cookie http header

Question

For some reason WordPress is setting “Set-Cookie” in the header of the entire site, this is telling my cache server not to cache the page, I tried to remove it via .htaccess, but it disabled the entire site and not I was able to log in more to the admin panel

How can I remove the “Set-cookie” from the http headers only on the frontend of my website? This is in the home, tags, search, blog, etc…

curl -I https://meusite.comHTTP/1.1 200 OK
Date: Sun, 12 Sep 2021 22:19:41 GMT
Set-Cookie: ppwp_wp_session=0000000000000000000000000000000000000000000000000 expires=Sun, 12-Sep-2021 22:49:41 GMT; Max-Age=1800; path=/
cache-Control: public s-maxage=230
Link: <https://meusiet.com/wp-json/>; rel="https://api.w.org/"
Link: <https://meusiet.com/wp-json/wp/v2/posts/1087>; rel="alternate"; type="application/json"
Link: <https://meusiet.com/?p=1087>; rel=shortlink
Content-Type: text/html; charset=UTF-8
Transfer-Encoding: chunked
X-CACHE: miss
Alt-Svc: clear

in progress 0
Leonardo 1 week 2021-09-12T17:32:53-05:00 0 Answer 0 views 0

Answer ( 1 )

    0
    2021-09-19T04:09:45-05:00

    WordPress isn’t doing this, if I search for ppwp_wp_session aka ppwp, I get thousands of results for Password Protect WP. Either disable that plugin or contact their support for help.

Leave an answer

Browse
Browse