.htaccess – PHPS source file – 403 Forbidden You don’t have permission to access this resource

Question

Hi I am trying to view a .PHPS source file on Ubuntu 20.04.3 Apache 2.4.41 PHP 7 server but when I view the .phps file in the browser I get this message –

403 Forbidden You don’t have permission to access this resource.

If I rename the file type to .txt I can view the file fine in the browser.

I’ve added the following to .htaccess –

<FilesMatch ".phps$">
    SetHandler application/x-httpd-php-source
</FilesMatch>
        
RewriteRule (.*.php)s$ $1 [H=application/x-httpd-php-source]

And I tried adding that to /etc/apache2/sites-enabled/demo.testsite.com-le-ssl.conf but it didn’t work.

I then updated this file /etc/apache2/mods-available/php7.3.conf and commented out Require all denied and also added Order Deny,Allow and Deny from all

<FilesMatch ".+.phps$">
    SetHandler application/x-httpd-php-source
    # Deny access to raw php sources by default
    # To re-enable it's recommended to enable access to the files
    # only in specific virtual host or directory
    #Require all denied
    Order Deny,Allow
    Deny from all
</FilesMatch>

I then restarted apache sudo service apache2 restart and I still get this message in the browser when viewing the PHPS file –

403 Forbidden You don’t have permission to access this resource.

Has anyone got any idea how to fix?

0
wheretheresawill 2 weeks 2021-11-15T18:40:01-05:00 0 Answers 0 views 0

Leave an answer

Browse
Browse