How to fix broken database (plugin editor always shows ‘active’)

Question

I have a multisite. I tried to disable plugins by using phpmyadmin wp_sitemeta -> active_sitewide_plugins. I think I put the wrong value for a bit and it was broken. I was able to restore to the correct settings. Except now I can no longer use the plugin editor.

First of, the plugin editor always shows (active) when it’s not active. Second, when I try to edit it always says Unable to communicate back with site to check for fatal errors, so the PHP change was reverted. You will need to upload your PHP file change by some other means, such as by using SFTP.

Everything seems to work perfectly besides those 2 things. wp_sitemeta -> active_sitewide_plugins seems to show the correct values whenever I activate / deactivate plugins. Only plugin editor is bugged out.

How can I fix this? I can’t really do a fresh install, it would take too long to reinstall everything. I could do a partial fix if I can keep all the multisite settings the same somehow.

edit: it seems that part of the problem is wp_options -> active_plugins doesn’t update when I activate/deactivate plugins. Is there a way to fix it? I manually set it to a:0:{} but it’s not updating when I activate / deactivate.

--------------------------------------------------

>>> Share a link to this question, just copy and paste the code bellow on your web page <<<

<a href="https://www.wptricks.com/question/how-to-fix-broken-database-plugin-editor-always-shows-active/">

How to fix broken database (plugin editor always shows 'active')</a>
0
, , , johnw123 6 months 0 Answers 47 views 0

Leave an answer