How disable SSL redirect for specific URL?

Question

I have a specific URL that has to be accessible without SSL, so that some old devices can access it. The reason is those old devices have the URL hardcoded.

The URL is http://domain.com/server

My .htaccess looks like this:

RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

Redirect 301 /server http://sub.domain.com/server

However, the devices can’t even access the first URL because it keeps redirecting to https://domain.com/server

--------------------------------------------------

>>> Share a link to this question, just copy and paste the code bellow on your web page <<<

<a href="https://www.wptricks.com/question/how-disable-ssl-redirect-for-specific-url/">

How disable SSL redirect for specific URL?</a>
0
, , Leon H. 3 months 0 Answers 46 views 0

Leave an answer