headers – WordPress website goes to 404 if browser has Japanese as secondary language


I am stuck at some strange issue looking for help. I do have a site which opens on all browser without any issue. But when we add Japanese language into Browser from Settings -> Languages -> Add Language

Browser Language Settings

the site goes to 404.
enter image description here

After checking this in detail I found that when only Japanese language is added on browser then in request accept-language header ja;q=0.8,ja-JP;q=0.7 added as extra lines. So I am hoping that server or WordPress is not able to handle the extra parameters in accept-language header. However any other multilingual site is working on my browser.

    fetch("https://transcosmos.com/", {
  "headers": {
    "accept": "text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.7",
    "accept-language": "en-US,en;q=0.9,ja;q=0.8,ja-JP;q=0.7",
    "cache-control": "no-cache",
    "pragma": "no-cache",
    "sec-ch-ua": "\"Google Chrome\";v=\"111\", \"Not(A:Brand\";v=\"8\", \"Chromium\";v=\"111\"",
    "sec-ch-ua-mobile": "?0",
    "sec-ch-ua-platform": "\"Windows\"",
    "sec-fetch-dest": "document",
    "sec-fetch-mode": "navigate",
    "sec-fetch-site": "same-origin",
    "sec-fetch-user": "?1",
    "upgrade-insecure-requests": "1"
  "referrer": "https://transcosmos.com/voice-biometrics/",
  "referrerPolicy": "strict-origin-when-cross-origin",
  "body": null,
  "method": "GET",
  "mode": "cors",
  "credentials": "include"

I have disabled all security plugins, removed any extra code on .htaccess, but it does not help much. I look forward to server support but they didn’t help much as the request is being already served by WordPress which we can see in second screenshot. Any idea what should I look for?

Sanjay Goswami 2 months 2023-03-27T09:17:26-05:00 0 Answers 0 views 0

Leave an answer