Disable SSL / HTTPS for wordpress

Question

I’ve installed WordPress and setup the database.
I go to the address and the setup page is there, but no CSS.
I think: something’s wrong, but if I just do the setup maybe everything will just go back to normal.
No.
So then I spend a while looking through search results for WordPress styles not working etc.
I discover that all the links are present in the head of the page(s), and they point to the right pages, but they are not being loaded.
WordPress is trying to use a secure connection, but I don’t have an SSL certificate or anything like that and I shouldn’t think I’ll need one for this either. This means that all the links to stylesheets and scripts are seen as untrustworthy and blocked.
I changed my searches to point in the direction of disabling https / ssl, but nothing I have found works.
E.g. I’ve tried adding stuff to my .htaccess file (lost the link to another related question on this site)
I’ve tried to find lines like define( 'force_SSL', true ); in wp-config.php but to no avail (related question). I’ve tried adding these lines (switching them to false) as well.

Thanks for any help.

Solution:
The problem was not what I thought it was. Dataplicity (I am running off a pi) forces use of HTTPS, but as wordpress wasn’t using HTTPS, the ‘insecure’ scripts weren’t being loaded. All I needed to do was enable HTTPS.

I’m sure the answers below would have helped if my problem was what I thought it was, and I hope they’ll help others with the same problem as I thought I had.

0
, , , , cCe.jbc 1 year 2020-07-17T08:10:33-05:00 0 Answers 84 views 0

Leave an answer

Browse
Browse