block editor – Gutenberg build error: You may need an appropriate loader to handle this file type SCSS

Question

I had a plugin up and running with a scss to css compiler. Suddenly after I moved a few files into a better structure I get this error while building the block:

ERROR in ./blocks/random-game/src/style.scss 8:1
Module parse failed: Unexpected token (8:1)
You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file. See https://webpack.js.org/concepts#loaders
|  */
| 
>  .wp-block-random-game {
|   
| }
 @ ./blocks/random-game/src/index.js 15:0-22 

I don’t understand why this happens and where I have to add a loader. I started with the create block script and built the plugin from there. Everything else works:

[./blocks/random-game/src/edit.js] 1.45 KiB {index} [built]
[./blocks/random-game/src/index.js] 983 bytes {index} [built]
[./blocks/random-game/src/save.js] 487 bytes {index} [built]
[./blocks/random-game/src/style.scss] 277 bytes {index} [built] [failed] [1 error]

Any idea where I can add the loader?

0
Marc 9 months 2021-11-26T16:17:59-05:00 0 Answers 0 views 0

Leave an answer

Browse
Browse