async_upload.php 500 Error when Uploading larger files with slow internet connection and latency


my page runs on a local corporate network on a Windows 2016 server running IIS 10.
PHP 7.1
WordPress 5.3

The page is used as a video platform. Videos up to 2GB can be uploaded. From our locations on the same network (upload speed 25-50Mbps) the upload works without any problems.
The corresponding parameters in IIS, php.ini and wp-config.php are set correctly. The timeouts on the server and the proxies are set to 2 hrs.

The problem is:

Uploads >300MB will not complete from other locations over WAN.
The connection corresponds to approx. 4Mbps uploadspeed with 130ms latency. If I simulate the upload in Chrome with these settings, I will end up with a 500 error of async-upload.php. How can I optimize the page for slow connections and latency?

I am grateful for hints!

Chrome Network Log:

Request URL:
Request Method: POST
Status Code: 500 Internal Server Error
Remote Address:
Referrer Policy: strict-origin-when-cross-origin
Connection: close
Content-Length: 1208
Content-Type: text/html
Date: Mon, 02 Dec 2019 13:40:45 GMT
Server: Microsoft-IIS/10.0
X-Powered-By: XXX
Accept: /
Accept-Encoding: gzip, deflate, br
Accept-Language: de-DE,de;q=0.9,en-US;q=0.8,en;q=0.7
Connection: keep-alive
Content-Length: 518192654
Content-Type: multipart/form-data; boundary=—-WebKitFormBoundaryBYhwvYy8edwoTGJh
Cookie: wordpress_sec_8e85a50d55023e68686338106663e49d=mwerbro%7C1575444406%7CmsjSnLM6HQzCeaOxjCP7aKQvqApaGGc45mHp5xiJusy%7C1632275c6b5a9f9e15fbbac0896441e90e82a263ad537b7f64fa39488e5cc72b; vchideactivationmsg_vc11=6.0.5; catAccCookies=1; wp-settings-time-134=1575035781; wp-settings-134=libraryContent%3Dbrowse%26editor%3Dhtml%26edit_element_vcUIPanelWidth%3D649%26edit_element_vcUIPanelLeft%3D923px%26edit_element_vcUIPanelTop%3D74px%26posts_list_mode%3Dlist; wordpress_logged_in_8e85a50d55023e68686338106663e49d=mwerbro%7C1575444406%7CmsjSnLM6HQzCeaOxjCP7aKQvqApaGGc45mHp5xiJusy%7Cecc5ac52a0f081c9ec834ca0a2036b2bf44482f02a5f20e1184f7fa585053bc3; wp-wpml_current_admin_language_d41d8cd98f00b204e9800998ecf8427e=de;; _pk_ses.275.97ea=1; wp-wpml_current_language=de; _pk_id.275.97ea=4c61b23bd9343dc7.1571816982.119.1575293156.1575288534.; ADRUM=s=1575293617793&
Sec-Fetch-Mode: cors
Sec-Fetch-Site: same-origin
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.120 Safari/537.36
name: C0008.MP4
post_id: 0
_wpnonce: 523ff9aa48
short: 1
async-upload: (binary)

, , melvishb 4 years 2019-12-03T07:05:04-05:00 0 Answers 112 views 0

Leave an answer