admin – Unable to view theme options

Question

I am restructuring how my WordPress files are organized in order to use Composer along with tracking the theme and child theme in a Github repository. I’m following this guidance for the most part, except that I am tracking the theme and child theme in the same repository that I am using for the main site.

I’m using a child theme that I created which modifies the Neve theme. My theme code is in this github branch.

I did this restructuring on my local site (haven’t done it on the staging or production sites yet), and it mostly works, except that I can’t see the theme options in Wp-Admin (the submenu is supposed to show as “Appearance” > “Neve Child Options”). Because of this, my main menu content is not visible since the page header content including logo, title, and main nav menu is set in theme options.

Here’s what I see on the staging site:
Neve Child Options

Here’s what I see on the local site:
Appearance with no Neve Child Options

I toggled the active theme but this did not resolve the issue.

I came across this question which describes how to hide that submenu item using

function remove_ot_menu () {
remove_submenu_page( 'themes.php', 'ot-theme-options');
}
add_action( 'admin_init', 'remove_ot_menu' );

However, I searched for remove_submenu_page in code and found no occurrences of that in the directory that contains the entire local site.

I also thought it might have had to do with this which was originally in the wp-config-sample.php and at one point was in my wp-config.php

# Disables the embebeded editor
define( 'DISALLOW_FILE_EDIT', true);
define( 'DISALLOW_FILE_MODS', true);
define( 'RELOCATE', true);

So I commented these lines out like:

# Disables the embebeded editor
/*
define( 'DISALLOW_FILE_EDIT', true);
define( 'DISALLOW_FILE_MODS', true);
define( 'RELOCATE', true);
*/

which brought back the “Theme Editor” item under “Appearance” but did not bring back “Neve Child Options”.

Also, when I go directly to the corresponding url for “Neve Child Options” based on what it is in the staging site and change it to use the local url: http://localhost:8888/site-name/wp/wp-admin/themes.php?page=neve-welcome

I get “Sorry, you are not allowed to access this page.”

sorry, you are not allowed to access this page

I am debugging to debug.log, but it shows nothing that seems to be related to this.

What else could be causing this / how can I get the “Neve Child Options” back on my local site?

WordPress 5.6.1 | Neve theme 2.8.2

0
Mike Eng 2 months 2021-03-20T17:48:59-05:00 0 Answers 0 views 0

Leave an answer

Browse
Browse